Emulator issues: "Cannot Activate device. Business was not set up"

I’m trying to use your emulator in order to develop an app for the SmartPOS Nexi.

After signup as developer on eu.poynt.net, I have follow these steps:
0. I have create an Android emulator using AVD.

  1. I have downloaded the last version of software emulator (p61b-0917 - link in the forum)
  2. I have created a test merchant on your web portal with Nexi as Bank
  3. I have clicked on the link of email “You have been added as a manager for a Poynt business”
  4. I have selected the terminal and clicked on Activate Terminal
  5. On the emulator, I have configured my webcam as camera and read the QRCode correctly

When click on activate I receive this error “Cannot Active device. the Business was not set up”. I have tried the activation without the QRCode but Nexy is not available.

The same problem also occurs when I use the US backend and emulator with region us.

The workaround I found is as follows:

  1. Before try to activate the terminal open go to https://eu.poynt.net/mc
  2. In the left corner select organization
  3. Select the test merchant and navigate to https://eu.poynt.net/business
  4. Select manage store and update a value
  5. Try now the activation

This workaround doesn’t work from the mission control portal.

My question is, is this procedure correct? Is there an official procedure?

I found other issues that could be connected to the problematic activation, but I’ll post as different topics.

Could you please try the latest emulator for nexi

With this version of the emulator, appears several times this error:
“Unfotunatly, Poynt Service has stopped”

If I run the activation wizard, the application stops on the a screen “Check activation status”.

This the link to download the logcat: link.

The poynt services crash is expected, please re-run the script.