Debug/Developer mode on MacOS

Hi there!

I see some people run into this issue but none of the forum questions seem to have answers. Here are the details:

  • This is a devkit not a production terminal
  • Poynt PST3 - 4G Smart Terminal, Dual Screen
  • Poynt os version - poynt/pst3/pst3:10/QKQ1…
  • MacOS

I can deploy an app via Android studio in debug mode but I cannot debug I get:

“Waiting for application to start debug server
Could not connect to remote process. Aborting debug session.”

Looking at the instructions I see this:
" Make sure your device is properly connected via USB by running the fastboot devices command on your host machine."

but I get this

adb devices -l
List of devices attached
0123abcd               device usb:137560064X product:msm8953_64_pst3_q model:Poynt_PST3 device:msm8953_64 transport_id:4
 fastboot devices   
<nothing comes back>

I can then get into the fastboot device but when I run

fastboot flashing unlock

nothing happens… I wonder if I am doing somethig wrong for MacOS? Should I be able to see something when running fastboot devices ?

I also tried to see what was going on based on this:

" If your host machine runs on Linux and it does not recognize the device please follow the instructions starting at Step 3 in this Android User Guide"

but there is no longer a step 3 in that guide…

Any help is appreciated