Cannot inject keys. Please verify your device is registered with Poynt

Hey guys,

I am following the tutorial “” but I’m not succeeding to install the PoyntOS after last update.

I fill in the fields MID, TID and Bank correctly but displays the following error message: “Cannot inject keys. Please verify your device is registered with Poynt.”

I’m using:
OSX El Capitan 10.11.4
Android Studio 2.1
Poynt Emulator 1.2.11


1 Like

Hi Gabriel,

Thanks for reaching out. You can just click continue/OK and ignore that message. That sounds like a bug that we need to fix in the emulator build. Next time you restart the image you should not see that error.



I am having the same trouble with my environment. Same error message, same env. When I chose to ignore the error, it always returns to the QR code reader.

Thanks a lot,

Hey @neil,

It solved my problem.


Problem solved here too. Thanks guys.

Hello Guys,

I am too facing the same problem and tried all possible ways to sort it out as mention in the above discussion.

I have restarted the device but still getting the same message on click of Continue after entering the merchant ID and terminal ID.

On skipping the message I an getting the dialog box but whatever I press either Yes or No, It is taking me to the initial bank selection screen.

Please suggest how to solve this problem?

Thanks in advance!

1 Like

Hi Gabriel, how do you resolved this issue?


@cpineda – is this an emulator or a physical DevKit device?

I’m trying with both without any luck

If you’re still having problems, can you reach out to me via email (

I connected the device in another network and now it’s working, thanks