Cannot change merchant locale on Mission Control

I tried to change the locale on one of our test merchants (both in and but despite the save of new configuration was successfull, the merchant locale still persist US.

I noticed that after save, for a second or two, the displayed locale is IT, but it changes back immediately.

This block our tests with plans, because the android libraries sends to poynt services the currency US.

I tried to modify the currency on test store, re-install and re-confgure both the emulator and the physical device, but without result: the currency sent is ixed to USD (and on the platform I cannot change the currency of the plans)

please share the device serial number.

Thank you for your help. Here serial numbers of our two devices:



The problem still persists: I associated the physical device to eu test merchant.

I sill experience this problems:

  • I cannot change the merchant locale (it still be US instead of IT)

  • I cannot retrieve plans using Android API: I got 401 error from server (I saw the logs from netcat)
    Getting token

07-23 16:29:22.550 1495-1962/ I/POYNT-EVENT: {“time” : “2018-07-23T14:29:22Z”, “type” : “REST_API”, “status” : “SUCCESS”, “storeDeviceId” : “urn:tid:6d853774-8fcf-334f-ba4e-14bbf2915302”, “processingTime” : 822.865308, “method” : “POST”, “apiStatusCode” : 200, “apiRequestId” : “c78b70bb-0164-1000-ed2a-17d95fb2f02f”, “apiEndpoint” : “”, “apiServerDate” : “Mon, 23 Jul 2018 14:29:22 GMT”, “apiServerBuild” : “1.2.450-2018-07-17T22:00:56Z”, “apiServerInstanceId” : “i-05ebcee7ff08a538c”}
07-23 16:29:22.551 1495-1962/ D/CLOUD-API: <— HTTP 200 (827ms)
OkHttp-Selected-Protocol: h2
date: Mon, 23 Jul 2018 14:29:22 GMT
content-type: application/json;charset=UTF-8
set-cookie: AWSALB=4a/PLz1wwll23ovsr//s6Kwe5jznTW3rXd1KMpoFvOWEQL0TmEwKrxKKYbzAhgWp1qh+PI/o0bWtaqOVKqSkzr6CfGmpqhaLGur8vOSKtBPG6PxFG5js+L8PkGDg; Expires=Mon, 30 Jul 2018 14:29:22 GMT; Path=/
server: Apache-Coyote/1.1
poynt-request-id: c78b70bb-0164-1000-ed2a-17d95fb2f02f
poynt-build-info: 1.2.450-2018-07-17T22:00:56Z
instance-id: i-05ebcee7ff08a538c
OkHttp-Sent-Millis: 1532356162238
OkHttp-Received-Millis: 1532356162549

Getting plans

07-23 16:29:23.462 1866-12145/? D/OkHttp: <-- 401 Unauthorized (893ms)
Content-Type: application/json
Date: Mon, 23 Jul 2018 14:29:23 GMT
Server: Apache-Coyote/1.1
Content-Length: 130
Connection: keep-alive
07-23 16:29:23.463 1866-12145/? D/OkHttp: {“code”:“INVALID_ACCESS_TOKEN”,“httpStatus”:401,“message”:“Access token is missing or invalid”,“developerMessage”:“Invalid token”}

  • The currency still be USD instead of EUR (see previous log)

The locale is now changed to IT for both the devices, a reboot might be needed for changes to take effect.
We are fixing the issues with the billing, we will get back on this soon.

thanks for having fixed the merchant locale:

so now the currency seems to be correct.

By the way we still have problems with the token returned by the the API, so the previous call fails returning 401 Unauthorized (INVALID_ACCESS_TOKEN).

We hope you could fix these issues soon, as we are in a rush to do some developments based on billing services.

Thanks for your help.

Any update about this issue?


For all Billing related API calls, please use as the endpoint.
Your API call for fetching the Billing Plans would look something like this:{appID}/plans?currency=EUR&status=ACTIVE&status=INACTIVE

OK great,
thanks satya1.

Now our app can retrieve the testing plans we have created associated.

One more issue remains: both of our terminals (serial numbers

  • P6SW208JS003612
  • P6SW200JS003390


do not have application APPS installed in home. Without it

  • we cannot install the newer version you send us that permits to test the billings fragment
  • we cannot perform any subscription to test the related API call

Could you help us to install this application?

Thanks for all your support.

enabled APPS on both the devices