Activate Merchant icon (lightning bolt) throws error

Hi all,
when I try to activate my test merchant (by clicking in the bolt icon), nothing happens. If I look at the console, this error is shown:

vendor-9ab378e78bd0033881804a80b59c3d83.js:12 TypeError: e.get is not a function
at activateTerminal (atc-d1adeeb7bb4b1b932f21c7e1d9fa7d6f.js:8)
at a.send (vendor-9ab378e78bd0033881804a80b59c3d83.js:17)
at a.n [as send] (vendor-9ab378e78bd0033881804a80b59c3d83.js:16)
at vendor-9ab378e78bd0033881804a80b59c3d83.js:10
at Object.h [as flaggedInstrument] (vendor-9ab378e78bd0033881804a80b59c3d83.js:12)
at vendor-9ab378e78bd0033881804a80b59c3d83.js:10
at (vendor-9ab378e78bd0033881804a80b59c3d83.js:8)
at Object.l [as run] (vendor-9ab378e78bd0033881804a80b59c3d83.js:13)
at e.handler (vendor-9ab378e78bd0033881804a80b59c3d83.js:10)
at HTMLDivElement. (vendor-9ab378e78bd0033881804a80b59c3d83.js:17)

I tried with 3 different browsers (Chrome- Firefox- Edge) and creating different test merchants, same result.
How can I solve this problem?

Thank you,

Hi Marco,
Please enter the TID and MID manually on the device to activate the device.
We are tracking the issue, expect it to be fixed sometime soon.

Hi deepak, thank you for your reply.
I have a TID like this one: pi59, but when my device asks for the TID, the keyboard that is shown is only a numeric keyboard, so I cannot enter the ā€˜pā€™ and the ā€˜iā€™.
My terminal serial number is P6SW185JS001543

I managed to enter the TID, now the terminal asks for:

  • Ip address
  • Port
  • Gt ID
    Where I can find these infos?


Hi @marcoagati147, please get in touch with me via e-mail (